Save as PDF

Working with Response Templates

Overview

Response templates are Word documents with defined styles that can be customized with your corporate branding. You can add images, boilerplate text, and branding accents to the template to give it a tailored look and feel. The application reads the style guides you select for sections, questions, and answers. You can use the default styles or create your own. This article outlines how to set up a Response template within Word and how to import into the application.

You want to create a branded template tailored to your organization, or dynamically add finishing touches to a project upon export to reduce the finishing work outside of the application.

Select the applicable tab for your edition of Responsive.

  • Topics Included in this Article

    Creating Custom Templates

    Begin by creating your styles in Word.

    • The default answer style is Normal. To change the default, use the Modifying Existing Styles process below.
    • You can also customize styles for sections, questions and sub-questions, tables, tables of contents (TOCs), lists, and more.

    Modifying Existing Styles

    1. Right-click on the style you want to modify in the style gallery.
    2. Click Modify.
      Note: You can modify any attributes of the style such as color, size, weight, line height, spacing, padding, and more.
      mceclip1.png
    3. Modify the attributes and click Ok.
      Note: While using images with Response templates, use Line spacing: Multiple when specifying a line height for your answer style to ensure the image displays fully upon export. Specifying an exact line spacing truncates part of the image in the exported file.
      mceclip2.png

    Creating New Styles

    1. Click the down arrow on the right side of the style gallery and click Create a Style.
      mceclip4.png
    2. Modify the attributes, add a name, and click Ok.
      mceclip5.png
    3. Repeat the process for questions, sub-questions, or any other items you need styles for. When done, a preview of the assigned style appears in the style bar.
      mceclip6.png

    Creating Table Styles

    You can also customize your own table styles.

    1. Click the Insert menu, then open the Table drop-down and select the table size you want.
      mceclip10.png
    2. Right click and select New Table Style.
      mceclip11.png
    3. Customize your table style. You can change the style name, border color, font style and more.
      mceclip12.png
    4. Click OK to save your changes. Your table style appears in the Style Gallery.
      mceclip13.png
    5. ! Important: After defining and creating your table style, delete the table in your document.
      Note: A table style applies the defined style to all of the content within a section, and to tables in an individual response. The table style can be enabled on at the export screen as shown in the following image by checking the box on the sections you want in a table. Your content will then export in your defined table style.

    Creating List Styles

    You are able to create a style for how lists are handled from bulleted to numerical/alphabetical as well as mixed combinations. In the following section, the method of creating a custom bullet list style will be demonstrated.

    1. Navigate to the define new bullet interface and customize your options (such as the bullet shape and its starting indentation); then click OK.
      Screen_Shot_2020-04-03_at_2.40.07_PM.png
    2. On the style window, apply that bullet customization to text to use that foundation to create a new paragraph.
      Screen_Shot_2020-04-03_at_2.42.24_PM.png
    3. Repeat this process to capture the needed bullet sequence and to account for the different levels of content organization needed for your template. You should see a similar arrangement as shown below before moving back into the application to synchronize your style choices.
      • Now, when you upload a template, the options are available for list styles.
      • Once the template upload is complete, all bulleted lists that exist in your answer fields follow the template standards upon export.

    Creating Tables of Contents

    You can also include a TOC or any other content pages within your template. You can customize the name of the TOC, the font size, color, and weight, or choose a pre-built format from the TOC style gallery.

    1. From the References tab, click Table of Contents and select Custom Table of Contents from the drop-down list.
      mceclip15.png
    2. Click Options to customize what you want to appear in the table of contents.
      mceclip16.png
    3. Delete the pre-set numbering and customize it and provide numbers to the styles (such as 1,2,3).
      mceclip17.png
    4. If you only want section names to appear in the TOC, type 1 in the box next to Section in the list of available styles.
      mceclip18.png
    5. Click OK. You can now preview the print and web view of the TOC.
      mceclip19.png
    6. Right-click the TOC and click Update Field to refresh you TOC.
      • If there are entries in you TOC, they will be listed in the contents. Otherwise, no TOC entries will be found.
      • When exporting a project, you must right-click the TOC and select Update Field to populate the TOC.
        mceclip20.png

    Defining Where to Export Sections

    Sections from the application print at the end of templates by default. If you want your sections to export to a different place in your template:

    1. Type <<Sections Goes Here>> where you want the sections to print.
      Note: The <<sections goes here>> text will be replaced with your section content from the RFP upon export.
      sections-goes-here.png
    2. Save the template to your computer so you can upload the file into the application.

    Importing Your Templates

    1. From the Templates page, click New Template.
    2. Enter the template name, select the project type, and upload your response template file.
      Note: By default, the All project type is selected. You can remove it and add the required project types.
    3. Once your file is uploaded, map your styles with the elements of the RFx. Style selections include:

      • Section Style: Level 1 = Section; Level 2 = Subsection; Level 3 = Sub-subsection (sub-subsections can be created manually)
      • Question Style: Level 1 = Question; Level 2 = Sub-question; Level 3 = Sub-sub question (sub-sub questions can be created manually)
      • Answer Style: Applies to all answers
      • Table Style: Applies to all tables
      • Catalog Heading Style: Applies to all catalog headings
    4. Select Use Template Font Family and Size if you want to export the responses a template style you have defined.
      - Answer List Style: Level 1 = first level of bulleted list; Level 2 = second level of multi-level bulleted list
      - Response Prefix: Adds text that appears before each response (optional).
    5. Click Save to save the response template to the Templates page.

    Updating Templates

    • If only your static elements (such as title page graphics or appendices) need updated, click Update File within the Template Edit menu and upload the revised template.
    • If any of your styles fully changed, follow the processes above to select the new correct styles.
  • Essentials features are subscription-based and may not be available for all users. Contact your account manager, or accountmanagers@responsive.io, for more details.

    Topics Included in this Article

    Creating Custom Templates

    Begin by creating your styles in Word.

    • The default answer style is Normal. To change the default, use the Modifying Existing Styles process below.
    • You can also customize styles for sections, questions and sub-questions, tables, tables of contents (TOCs), lists, and more.

    Modifying Existing Styles

    1. Right-click on the style you want to modify in the style gallery.
    2. Click Modify.
      Note: You can modify any attributes of the style such as color, size, weight, line height, spacing, padding, and more.
      mceclip1.png
    3. Modify the attributes and click Ok.
      Note: While using images with Response templates, use Line spacing: Multiple when specifying a line height for your answer style to ensure the image displays fully upon export. Specifying an exact line spacing truncates part of the image in the exported file.
      mceclip2.png

    Creating New Styles

    1. Click the down arrow on the right side of the style gallery and click Create a Style.
      mceclip4.png
    2. Modify the attributes, add a name, and click Ok.
      mceclip5.png
    3. Repeat the process for questions, sub-questions, or any other items you need styles for. When done, a preview of the assigned style appears in the style bar.
      mceclip6.png

    Creating Table Styles

    You can also customize your own table styles.

    1. Click the Insert menu, then open the Table drop-down and select the table size you want.
      mceclip10.png
    2. Right click and select New Table Style.
      mceclip11.png
    3. Customize your table style. You can change the style name, border color, font style and more.
      mceclip12.png
    4. Click OK to save your changes. Your table style appears in the Style Gallery.
      mceclip13.png
    5. ! Important: After defining and creating your table style, delete the table in your document.
      Note: A table style applies the defined style to all of the content within a section, and to tables in an individual response. The table style can be enabled on at the export screen as shown in the following image by checking the box on the sections you want in a table. Your content will then export in your defined table style.
      Screen_Shot_2020-03-30_at_10.44.57_AM.png

    Creating List Styles

    You are able to create a style for how lists are handled from bulleted to numerical/alphabetical as well as mixed combinations. In the following section, the method of creating a custom bullet list style will be demonstrated.

    1. Navigate to the define new bullet interface and customize your options (such as the bullet shape and its starting indentation); then click OK.
      Screen_Shot_2020-04-03_at_2.40.07_PM.png
    2. On the style window, apply that bullet customization to text to use that foundation to create a new paragraph.
      Screen_Shot_2020-04-03_at_2.42.24_PM.png
    3. Repeat this process to capture the needed bullet sequence and to account for the different levels of content organization needed for your template. You should see a similar arrangement as shown below before moving back into the application to synchronize your style choices.
      • Now, when you upload a template, the options are available for list styles.
      • Once the template upload is complete, all bulleted lists that exist in your answer fields follow the template standards upon export.

    Creating Tables of Contents

    You can also include a TOC or any other content pages within your template. You can customize the name of the TOC, the font size, color, and weight, or choose a pre-built format from the TOC style gallery.

    1. From the References tab, click Table of Contents and select Custom Table of Contents from the drop-down list.
      mceclip15.png
    2. Click Options to customize what you want to appear in the table of contents.
      mceclip16.png
    3. Delete the pre-set numbering and customize it and provide numbers to the styles (such as 1,2,3).
      mceclip17.png
    4. If you only want section names to appear in the TOC, type 1 in the box next to Section in the list of available styles.
      mceclip18.png
    5. Click OK. You can now preview the print and web view of the TOC.
      mceclip19.png
    6. Right-click the TOC and click Update Field to refresh you TOC.
      • If there are entries in you TOC, they will be listed in the contents. Otherwise, no TOC entries will be found.
      • When exporting a project, you must right-click the TOC and select Update Field to populate the TOC.
        mceclip20.png

    Defining Where to Export Sections

    Sections from the application print at the end of templates by default. If you want your sections to export to a different place in your template:

    1. Type <<Sections Goes Here>> where you want the sections to print.
      Note: The <<sections goes here>> text will be replaced with your section content from the RFP upon export.
      sections-goes-here.png
    2. Save the template to your computer so you can upload the file into the application.

    Importing Your Templates

    1. From the Templates page, click New Template.
    2. Enter the template name, select the project type, and upload your response template file.
      Note: By default, the All project type is selected. You can remove it and add the required project types.
    3. Once your file is uploaded, map your styles with the elements of the RFx. Style selections include:

      • Section Style: Level 1 = Section; Level 2 = Subsection; Level 3 = Sub-subsection (sub-subsections can be created manually)
      • Question Style: Level 1 = Question; Level 2 = Sub-question; Level 3 = Sub-sub question (sub-sub questions can be created manually)
      • Answer Style: Applies to all answers
      • Table Style: Applies to all tables
      • Catalog Heading Style: Applies to all catalog headings
    4. Select Use Template Font Family and Size if you want to export the responses a template style you have defined.
      - Answer List Style: Level 1 = first level of bulleted list; Level 2 = second level of multi-level bulleted list
      - Response Prefix: Adds text that appears before each response (optional).
    5. Click Save to save the response template to the Templates page.

    Updating Templates

    • If only your static elements (such as title page graphics or appendices) need updated, click Update File within the Template Edit menu and upload the revised template.
    • If any of your styles fully changed, follow the processes above to select the new correct styles.

Was this article helpful?

/